Back to overview
Degraded
Mapping Matter is experiencing degraded performance
Oct 09 at 01:59pm UTC
Affected services
disguise.cloud
Resolved
Oct 09 at 04:36pm UTC
The issue has been resolved.
Affected services
disguise.cloud
Created
Oct 09 at 01:59pm UTC
An upstream service provider is experiencing issues causing long loading times for Mapping Matter users. We are working with this partner to resume normal service.
Affected services
disguise.cloud